注册 登录  
 加关注
   显示下一条  |  关闭
温馨提示!由于新浪微博认证机制调整,您的新浪微博帐号绑定已过期,请重新绑定!立即重新绑定新浪微博》  |  关闭

奕克

爱家人爱工作爱生活

 
 
 

日志

 
 

Eclipse运行代码提示can't find class等  

2014-10-07 21:56:29|  分类: JAVA |  标签: |举报 |字号 订阅

  下载LOFTER 我的照片书  |
      今天运行一个随书光盘中的java swing应用程序,eclipse提示 can't find class jtable,安装的是oracle网站上刚下载的java 8update20,然后以为是程序中的类不兼容java8,换成了java6update7,一直提示好多错误,还以为自己eclipse没配置对,按以下网上找到的步骤配置:
  1. There must be an installed (and selected) JDK in Eclipse:

    Window > Preferences > Java > Installed JREs   
    
  2. The project must be configured to use that JDK:

    Project > Properties > Java Build Path > Libraries
    

    there should be an entry like "JRE System Library [JDK7]" in the list. If not press:

    Add Library... > JRE System Library
    
  3. The project should have been created as a "Java Project":

    Project > Properties > Builders
    

    should include "Java Builder"


    但是依然不行,后来才发现,上次在机房运行时的jdk是1.6update20,自己老的机子上的是1.6update24,然后机房里那个1.8不知道是update几,但肯定没到20.

    可见jdk每个版本的类都有点稍微不同吧,需要参考随软件安装的文档,那些随书光盘中的java软件,应该提示一下开发时的java版本update几,最好附带jdk软件。

    感觉java版本太多了,还是。net就那么几个版本好。

    最后注意eclipse有时运行不了的话,看看系统环境变量中的classpath,path和java_home是否已经设置。

  评论这张
 
阅读(88)| 评论(0)
推荐 转载

历史上的今天

在LOFTER的更多文章

评论

<#--最新日志,群博日志--> <#--推荐日志--> <#--引用记录--> <#--博主推荐--> <#--随机阅读--> <#--首页推荐--> <#--历史上的今天--> <#--被推荐日志--> <#--上一篇,下一篇--> <#-- 热度 --> <#-- 网易新闻广告 --> <#--右边模块结构--> <#--评论模块结构--> <#--引用模块结构--> <#--博主发起的投票-->
 
 
 
 
 
 
 
 
 
 
 
 
 
 

页脚

网易公司版权所有 ©1997-2017